Investigating service disruption on Fleetworks, FleetCockpit and FleetCockpit+

Incident Report for Platform Science Europe

Resolved

System stability has been fully restored across FleetWorks, FleetCockpit, and FleetCockpit+.

To ensure long-term reliability, the "Places" feature has been temporarily disabled while we implement architectural optimizations and enhanced caching mechanisms.
We will provide further updates through standard release notes when the feature is ready to be re-enabled.

Thank you for your patience.
Posted Mar 24, 2026 - 14:15 CET

Monitoring

Systems are stable. We are currently monitoring performance to ensure continued reliability.
Posted Mar 19, 2026 - 13:28 CET

Identified

As part of our ongoing investigation into the recent performance issues, we have temporarily disabled the "Places" feature in FleetCockpit+. This measure is intended to stabilize system resources and prevent further connection pool saturation.

Required Action for Users:
To ensure these changes take effect and to restore optimal performance on your side, we kindly ask all users to clear their browser cache and cookies before logging back into the applications.

Our engineering team is monitoring the impact of this deactivation.
Thank you for your cooperation and patience.
Posted Mar 19, 2026 - 11:45 CET

Investigating

We’re currently experiencing a service disruption on Fleetworks, FleetCockpit and FleetCockpit+
Users may be experiencing a performance issue on these applications

Our team is working to identify the root cause and implement a solution.

We're working hard to fix the issue and will update you as soon as we have more information.
Posted Mar 19, 2026 - 10:18 CET
This incident affected: Fleetworks (FleetWorks web application) and FleetCockpit, FleetCockpit+.