Our team has determined that the previously reported issue is now fully resolved. Thank you for your patience during this incident.
Posted Mar 17, 2026 - 19:55 CET
Update
We are continuing to monitor for any further issues.
Posted Mar 17, 2026 - 16:12 CET
Monitoring
Service levels for FleetWorks, FleetCockpit, and FleetCockpit+ have returned to normal. We are closely monitoring the situation to ensure continued stability.
Posted Mar 17, 2026 - 16:08 CET
Update
We have observed that service levels for FleetWorks, FleetCockpit and FLeetCockpit+ have returned to normal. Looking to identify the root cause we keep monitoring the situation.
Posted Mar 17, 2026 - 12:47 CET
Investigating
We are currently experiencing a service disruption affecting FleetWorks, FleetCockpit and FLeetCockpit+.
User Impact: Users may experience significant slowness within the applications. Additionally, some users may be automatically logged out and required to log in multiple times.
Our engineering team is actively working to identify the root cause and implement a solution as quickly as possible. We will provide another update as soon as more information becomes available.
Posted Mar 17, 2026 - 11:58 CET
This incident affected: Fleetworks (FleetWorks web application) and FleetCockpit, FleetCockpit+.