Web applications: degraded performance
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted Nov 22, 2019 - 16:59 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 22, 2019 - 16:35 CET
Investigating
We are currently investigating this issue.
Posted Nov 22, 2019 - 16:32 CET
This incident affected: Fleetworks, Fleetcockpit, and Fleethours.