We are continuing to monitor for any further issues. Currently, the problem is still affecting customers with large fleets. A workaround is available: customers are advised to use the global filters to select specific vehicles or drivers.
Posted Sep 15, 2025 - 08:45 CEST
Monitoring
A Fix has been implemented we are monitoring the results.
We apologize for any inconvenience this may cause.
Please contact support if you have further questions.
Posted Sep 11, 2025 - 14:37 CEST
Identified
The issue has been identified from our side side and a fix is being implemented
We apologize for any inconvenience this may cause.
Please contact support if you have further questions.
Posted Sep 11, 2025 - 14:07 CEST
Investigating
Our team is investigating an issue on the following service(s): FleetCockpit+
We have identified an incident affecting the FleetCockpit+. Users are experience slow performance or pages not displaying. We sincerely apologize for the service interruption and will provide further updates as soon as possible.