FLeetCockpit degraded performance
Incident Report for Trimble Transport & Logistics
Resolved
We could see the system performance is back to normal and all components operating normally
Posted Oct 08, 2019 - 17:28 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 08, 2019 - 17:06 CEST
Investigating
We are currently investigating this issue.
Posted Oct 08, 2019 - 16:44 CEST
This incident affected: Fleetcockpit.