Service disruption: Delayed Data Processing

Incident Report for Platform Science Europe

Resolved

Processing delays have been resolved, and the system is back to normal.
We will continue to monitor the situation closely to ensure continued stability.
We appreciate your patience while we worked to restore our service standards.
Posted Apr 14, 2026 - 21:12 CEST

Monitoring

A fix has been deployed, and we are currently monitoring the recovery.
We expect the processing backlog to clear shortly.
Thank you for your patience.
Posted Apr 14, 2026 - 14:16 CEST

Identified

The issue has been identified and a fix is currently being implemented.
We are working to restore normal service.

We apologize for any inconvenience this may cause
Posted Apr 14, 2026 - 13:25 CEST

Investigating

We are currently investigating performance issues affecting our trace processing pipeline.
As a result, users may experience a delays in data appearing on their dashboards.
Our engineering team is fully mobilized to restore normal service as quickly as possible.

We sincerely apologize for this disruption.
Posted Apr 14, 2026 - 12:59 CEST
This incident affected: Fleetworks (Trace Processing).