Service Interruption: BI Reports Recent data may not be reflected in reports and dashboards.

Incident Report for Platform Science Europe

Resolved

The issue has been resolved and the fix is fully deployed.
All BI reports and dashboards are now reflecting the latest data.

We apologize for the interruption to your workflow and appreciate your continued support.
Posted Apr 09, 2026 - 15:04 CEST

Identified

We have identified the cause of the data discrepancy affecting our BI reporting suite.
Our engineering team is currently working on a fix to restore full data accuracy.

We apologize for any inconvenience this may cause.
Thank you for your patience and consideration.
Posted Apr 09, 2026 - 13:24 CEST
This incident affected: Fleetworks (Reporting).