Maps View (FleetWorks & FleetCockpit): The map display in FleetWorks and FleetCockpit and Traffic info on client devices is resolved. We will keep monitoring
Posted Oct 20, 2025 - 13:56 CEST
Update
Our phone support availability is resolved.
Posted Oct 20, 2025 - 13:16 CEST
Update
We are continuing to investigate this issue.
Posted Oct 20, 2025 - 13:08 CEST
Investigating
We are currently investigating a partial service disruption affecting several services.
Affected Services:
Maps View (FleetWorks & FleetCockpit): The map display in FleetWorks and FleetCockpit is currently unavailable.
Traffic Information: We are also experiencing issues with traffic information display on client devices.
Telephone Support: Our phone support availability is currently degraded due to a telephone system issue.
Workarounds:
For Maps: Please use FleetCockpit Plus as an alternative.
For Support: Please raise a support ticket via email for assistance.
We apologize for the inconvenience and are working to resolve these issues as a high priority. We will provide an update as soon as more information is available.
Posted Oct 20, 2025 - 11:51 CEST
This incident affected: External and Support Availability.