Investigating service disruption

Incident Report for Platform Science Europe

Resolved

Services are now operating normally, and we will continue to monitor to ensure stability.
We remain actively engaged to ensure system stability is maintained.
Posted Jul 14, 2026 - 14:46 CEST

Monitoring

A fix has been successfully implemented, and the Customer Hub, along with all associated applications are now fully accessible again.

Our team is continuing to closely monitor system health and performance to ensure ongoing stability.

Thank you again for your patience.
Posted Jul 14, 2026 - 12:16 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 14, 2026 - 12:07 CEST

Update

We are continuing to work on a fix for this issue.
Posted Jul 14, 2026 - 12:01 CEST

Identified

The issue has been identified on our side, and a fix is being implemented.

We apologize for any inconvenience this may cause.
Posted Jul 14, 2026 - 12:01 CEST

Investigating

We’re currently experiencing a service disruption on the customer hub and all applications.

Our team is working to identify the root cause and implement a solution.

Users may be experiencing:

Slow loading times or intermittent error messages.

Difficulty logging in to their accounts.

Delays in accessing the Customer Hub and applications.

We're working hard to fix the issue and will update you here as soon as we have more information.

Thank you for your patience.
Posted Jul 14, 2026 - 11:40 CEST
This incident affected: Customer HUB, Document Management System, FleetCockpit+, FleetHours Web, Performance Portal and Fleetworks (Reporting, FleetWorks web application).