We are pleased to announce that the mapping functionality in FleetHours has been fully restored. Thank you for your patience and understanding during this period.
Posted Mar 12, 2026 - 16:45 CET
Update
We are currently awaiting final verification from our service provider to restore mapping services.
Our team is monitoring the situation closely and will confirm as soon as the maps are back online.
We apologize for the continued inconvenience.
Posted Mar 12, 2026 - 13:57 CET
Identified
The issue has been identified, and a fix is being implemented.
We apologize for any inconvenience this may cause.
Please contact support if you have further questions.
Posted Mar 11, 2026 - 12:38 CET
Update
We are continuing to investigate this issue.
Posted Mar 11, 2026 - 09:35 CET
Investigating
We are currently experiencing an issue with the mapping display within FleetHours. Customers will temporarily be unable to view or use maps within the FleetHours.
Our team is actively working to renew the license and restore service as quickly as possible.
We apologize for the inconvenience and will provide updates as they become available.
Posted Mar 11, 2026 - 09:25 CET
This incident affected: FleetHours (SaaS) and FleetHours Web.