Web platforms degraded performance
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 11, 2019 - 10:40 CEST
Investigating
We are currently investigating this issue.
Posted 3 months ago. Jul 11, 2019 - 10:14 CEST
This incident affected: Fleetworks and Fleetcockpit.