No Polish phone support
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted Jul 30, 2019 - 08:06 CEST
Identified
Due to holiday and illness we currently have no Polish speaking phone support. Other languages are staffed.
Posted Jul 29, 2019 - 08:37 CEST