The issue impacting the FleetHours web application has been fully resolved. Corrective measures have been successfully deployed, and the application service is now fully operational and stable. All systems are back to normal performance.
We apologize for any inconvenience this service disruption may have caused and thank you for your patience and understanding.
Posted Sep 15, 2026 - 20:31 CEST
Identified
We have identified the cause of the issue affecting the FleetHours web application. Our engineering team is currently applying a fix to restore service as quickly as possible.
Posted Sep 15, 2026 - 17:16 CEST
Investigating
We are currently experiencing a service disruption on the FleetHours web application, resulting in a 504 Gateway Time-out error.
Our team is working to identify the root cause and implement a solution.
We're working hard to fix the issue and will update you as soon as we have more information.