Fleethours SAAS disruption

Incident Report for Platform Science Europe

Resolved

Services are now operating normally, and we will continue to monitor to ensure stability.
We remain actively engaged to ensure system stability is maintained.
Posted Jun 30, 2026 - 10:20 CEST

Monitoring

A fix has been implemented, and we are monitoring the results
Posted Jun 30, 2026 - 10:13 CEST

Identified

We’re currently experiencing a service disruption.

To apply the fix, the application needs to be restarted.

Action Required: > We are requesting that all users manually close and exit the application as soon as possible.

Please note that when the platform restarts, any remaining active users will be automatically logged out (kicked out) of the system.

We apologize for the brief interruption and appreciate your quick cooperation.
We expect the platform to be fully stable and available shortly.
Posted Jun 30, 2026 - 09:49 CEST
This incident affected: External.