Transport & Logistics Service Interruption on FleetHours (SaaS) Service(s)

Incident
May 26 2025, 12:00 CEST

Transport & Logistics Service Interruption on FleetHours (SaaS) Service(s)

Status: closed
Start: May 23 2025, 08:00 CEST
End: May 26 2025, 12:00 CEST
Duration: 3 days 4 hours
Affected Components:
FleetHours (SaaS)
Update

May 23 2025, 08:00 CEST

May 23 2025, 08:00 CEST

Our team is investigating an issue on the following service(s):

FleetHours (SaaS)


We sincerely apologize for the service interruption and will provide further updates as soon as possible.

Resolved

May 26 2025, 12:00 CEST

May 26 2025, 12:00 CEST

Service Interruption Affecting Service(s):

FleetHours (SaaS)


Our team has determined that the previously reported issue is now fully resolved. Thank you for your patience during this incident.