Web platforms unavailable
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted Jun 03, 2021 - 10:04 CEST
Monitoring
A refresh of your browser might be needed to recover the webapplications.
Posted Jun 03, 2021 - 09:51 CEST
Investigating
We are currently investigating this issue.
Posted Jun 03, 2021 - 09:39 CEST
This incident affected: Fleetworks and Fleetcockpit.