FleetXPS app not available in the Google Play Store
Incident Report for Trimble Transport & Logistics
Resolved
As from now the FleetXPS app is available again on the Play Store to install and update.
Please update all apps on devices through the Play Store to the new version that is available.
Posted Dec 16, 2020 - 12:02 CET
Update
On the Play Store, we regularly update our application and the requirements specified by Android are often changed as well. As a result, our application has been temporarily flagged as not compliant with Google policies and it has been suspended from the Play Store as well.

Please be assured that the FleetXPS app is secure and that it is not necessary to uninstall the app. If you uninstall the app, you may have to provision your device again when you reinstall.

Our technical teams are in close contact with Google Play Store support to resolve this inconvenience as soon as possible.

If you want to install the FleetXPS app on a new device, you will be able to scan the QR code on My Trimble T&L as a temporary solution.
Posted Nov 19, 2020 - 11:09 CET
Update
We are continuing to work on a fix for this issue.

As a workaround we've made the app available, via QR code, on my.trimbltl.com.
Do note that this is a temporary fix and we will return to install the app through the Play Store.

Devices installed this way will be able to update through the Play Store once the issue is fixed.
Posted Nov 19, 2020 - 10:13 CET
Update
We are continuing to work on a fix for this issue.

As a workaround we've made the app available, via QR code, on my.trimbltl.com.
Do note that this is a temporary fix and we will return to install the app through the Play Store.

Devices installed this way will be able to update through the Play Store once the issue is fixed.
Posted Nov 16, 2020 - 16:12 CET
Identified
The issue has been identified and we are working with the Google Play Store to fix this.
Posted Nov 16, 2020 - 10:21 CET
Investigating
We are currently investigating this issue.
Posted Nov 12, 2020 - 10:09 CET
This incident affected: External Components (Provider Connectivity).