Web platforms unavailable
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted about 1 month ago. Sep 19, 2019 - 09:37 CEST
Update
We are continuing to monitor for any further issues.
Posted about 1 month ago. Sep 19, 2019 - 09:33 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 1 month ago. Sep 19, 2019 - 09:33 CEST
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Sep 19, 2019 - 09:27 CEST
This incident affected: Fleetworks and Fleetcockpit.