Web platforms unavailable
Incident Report for Trimble Transport & Logistics
Resolved
This incident has been resolved.
Posted Jun 01, 2021 - 17:14 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 01, 2021 - 16:37 CEST
Investigating
We are currently investigating this issue.
Posted Jun 01, 2021 - 16:30 CEST
This incident affected: Fleetworks and Fleetcockpit.